The World of Layonara  Forums

Author Topic: F keys not working in Wine  (Read 242 times)

jadewillow

F keys not working in Wine
« on: December 25, 2018, 08:14:03 pm »
Hey, anyone come across this? I'm running on Wine on Mac OS and my hotkeys (F1 etc) don't seem to be working.
 

Chazzler

Re: F keys not working in Wine
« Reply #1 on: December 27, 2018, 11:12:13 am »
I did a quick search on Google and came up with this.
(If you prefer the top row of keys to always behave as standard function keys without holding the Fn key:

    Choose System Preferences from the Apple menu.
    Click Keyboard.
    Click the Keyboard tab if it's not already highlighted.
    Select "Use all F1, F2, etc. keys as standard function keys")
 

jadewillow

Re: F keys not working in Wine
« Reply #2 on: December 28, 2018, 10:42:12 pm »
Thanks Chazzler. I should have been more specific. I have a docking station with a usb macally keyboard. Although your suggestion works for the laptop keyboard, it does not seem to work for the macally usb keyboard.
 

jadewillow

Re: F keys not working in Wine
« Reply #3 on: December 29, 2018, 09:57:28 am »
Figured this out for anyone with similar. As well as setting as above (Chazzler's post), my keyboard has a 'shortcut' light. When on, the F keys take the special mac functions (cut, paste, etc). It must be turned off (Fn-Down button for me) to enable the standard F keys.
 

WarriorOfTheLance

Re: F keys not working in Wine
« Reply #4 on: January 05, 2019, 02:28:22 am »
Function keys do not work

If your F<num> keys do not work, this is probably because the kernel driver for the keyboard has defaulted to using the media keys and requiring you to use the Fn key to get to the F<num> keys. To change the behavior temporarily, append 2 to /sys/module/hid_apple/parameters/fnmode.

# echo 2 > /sys/module/hid_apple/parameters/fnmode

To make the change permanent, set the hid_apple fnmode option to 2:

/etc/modprobe.d/hid_apple.conf

options hid_apple fnmode=2

To apply the change to your initial ramdisk, in your mkinitcpio configuration (usually /etc/mkinitcpio.conf), make sure you either have modconf included in the HOOKS variable or /etc/modprobe.d/hid_apple.conf in the FILES variable. You would then need to regenerate the initramfs.

if you need more help I can help you... I compile my own kernels and everything else in linux myself.
I don't personally run Arch as a main distro, I run Gentoo, but they are related and I do get a lot of help for my own problems from Arch wikis. I have run nearly every distribution of linux. What distribution are you running on that mac? Ubuntu? Yellow Dog? Debian? (can't remember all the others that support mac (those may be old ppc versions of mac and not the new intel))
source : https://wiki.archlinux.org/index.php/Apple_Keyboard
« Last Edit: January 05, 2019, 02:36:18 am by WarriorOfTheLance »
 

 

anything