The World of Layonara  Forums

Author Topic: NWN Master Server  (Read 269 times)

Script Wrecked

NWN Master Server
« on: April 20, 2012, 04:25:53 am »
If you are tired of waiting for NWN authorising your player name against a Master Server which (still) isn't there, you can add the following line to your "hosts" file:

Quote
0.0.0.0      nwmaster.bioware.com



The hosts file is found here:

[INDENT]
[NOPARSE]Windows 95/98/Me|c:\\windows\\hosts
Windows XP/Vista/7|c:\\windows\\system32\\drivers\\etc\\hosts
Mac OS X 10.0 – 10.1.5|(via NetInfo or niload)
Mac OS X 10.2 and newer|/etc/hosts
[/NOPARSE][/TABLE][/INDENT]


You will still have to click to acknowledge that it couldn't find the Master Server, but at least you won't have to wait for it.
 

davidhoff

Re: NWN Master Server
« Reply #1 on: April 20, 2012, 05:42:17 am »
Thanks Script,

I have windows xp and after c:\\windows\\system32\\drivers\\etc, I don't have "hosts"; I have "services", "networks" and "protocol".  So, not sure what to do now.

Davidhoff
 

Xaltotun

Re: NWN Master Server
« Reply #2 on: April 20, 2012, 07:05:18 am »
Thanks Script - this is a real help.

There are some issues with Windows 7 and I presume Vista too since they work the same way.

Although I could edit the file, it would not save it as it was already open (windows 7 on my machine). It also would not save it with a new name in the \\etc folder, so my solution was to:
  • save it with the same name in my Documents folder,
  • open Windows Explorer
  • Ctrl + drag the new file to the drivers\\etc folder as Script describes and overwrite the existing file. (Copy and Paste wouldn't work for me either, hence this option.)


This worked and I get the result Script says I should.

And ps, the /etc is actually a folder in Windows 7 and not a comment by Script to suggest etc, etc, sort of thing. :)
 

Script Wrecked

Re: NWN Master Server
« Reply #3 on: April 20, 2012, 08:03:44 am »
Quote from: davidhoff
Thanks Script,

I have windows xp and after [NOPARSE]c:\\windows\\system32\\drivers\\etc[/NOPARSE], I don't have "hosts"; I have "services", "networks" and "protocol".  So, not sure what to do now.

Davidhoff


Create the hosts file in the folder. Its a plain text file. Make sure that when you save it, it has no file extension, e.g., no ".txt" or similar.
 

miltonyorkcastle

Re: NWN Master Server
« Reply #4 on: April 20, 2012, 09:14:24 am »
This is very handy. Stickied.
 

Jilseponie Wyndon

Re: NWN Master Server
« Reply #5 on: April 20, 2012, 11:59:08 am »
This is what I see: [Host Folder]

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost


Where do I add this line?  And do I put a # before it?
 

davidhoff

Re: NWN Master Server
« Reply #6 on: April 20, 2012, 01:01:12 pm »
Quote
Create the hosts file in the folder. Its a plain text file. Make sure that when you save it, it has no file extension, e.g., no ".txt" or similar.


Thanks for the help Script.  I created a Miscrosoft Word document called "HOSTS", saved it in the ETC folder and in the body I wrote the info you suggested "0.0.0.0 nwmaster.bioware.com".  Then I changed to name to remove the .doc at the end.  It didn't speed up my NWN loading time...still  have to wait.  What did I mess up?  Do I need to do a restart?

Thanks again

EDIT: Ahhhh, ok, I got it to work now.  I had to change it to a "plain text file".  Now it works to skip the wait time on load.  Muchas Gracias.
 

Masterjack

Re: NWN Master Server
« Reply #7 on: April 20, 2012, 02:14:57 pm »
Quote from: Jilseponie Wyndon
This is what I see: [Host Folder]

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#    127.0.0.1       localhost
#    ::1             localhost


Where do I add this line?  And do I put a # before it?


I had the same thing. Just add the line to the bottom and save. The # sign in front of each line tells the computer to ignore that line. By adding the line it gives it something to do.

I had to make sure I had admin rights in order to save the file.

P.S. I was using Windows 7 64 bit.
 

Dorax Windsmith

Re: NWN Master Server
« Reply #8 on: April 20, 2012, 09:03:56 pm »
How do you make it a "plain text file"?  I only see 2 options

1) text documents (*.txt)
or
2) All Files
 

Script Wrecked

Re: NWN Master Server
« Reply #9 on: April 20, 2012, 09:32:15 pm »
Quote from: Dorax Windsmith
How do you make it a "plain text file"?  I only see 2 options

1) text documents (*.txt)
or
2) All Files


Are you creating the file, or editing an existing file? Which application are you using to edit the file?
 

davidhoff

Re: NWN Master Server
« Reply #10 on: April 20, 2012, 11:01:58 pm »
Quote
How do you make it a "plain text file"? I only see 2 options


I think what I did is I created a file in microsoft word first and didn't worry about it being "plain text" file.  Then when that didn't work, I think I either copied it or just open it and performed a "save as" action.  At the bottom of the save screen it had a drop-down list for "file type" (mine had about 10+ options for file type), and I chose plain text.  Hope that helps.
 

willhoff

Re: NWN Master Server
« Reply #11 on: April 21, 2012, 01:04:45 am »
Thanks Script,

I run wind xp and clicked on the "Hosts" file.  I got a pop window asking what program I wanted to open the file in and clicked on microsoft word.  All I saw was a single sentence and the rest of the page blank.  I pasted your formula "0.0.0.0 nwmaster.bioware.com" the next line under the existing sentence.  I clicked save under the file options.  I got a pop window that asked me if I wanted to save as a text file and I clicked yes.  Closed out the screens and it worked.
 

Xaltotun

Re: NWN Master Server
« Reply #12 on: April 21, 2012, 04:23:13 am »
For anyone struggling to edit or create the file Script talks about, I would advise using erither Notepad or Notepad 2 (for Windows based machines only) as they create the type of file you need. When you save the file, make sure you DO NOT save any extension with it, as the file needs to be called hosts and not hosts.txt, hosts.doc or anything else with a suffix.
 

Jilseponie Wyndon

Re: NWN Master Server
« Reply #13 on: April 21, 2012, 10:18:16 am »
I made the changes and unfortunately ... nothing changed. I still have to wait.  :(
 

Script Wrecked

Re: NWN Master Server
« Reply #14 on: April 21, 2012, 11:43:42 am »
Quote from: Jilseponie Wyndon
I made the changes and unfortunately ... nothing changed. I still have to wait.  :(


Your hosts file would now look like this:

Code: [Select]
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost
0.0.0.0 nwmaster.bioware.com


It should be in text format, with no extension. I am a little bit thrown by "[Host Folder]" in your earlier post.
 

Jilseponie Wyndon

Re: NWN Master Server
« Reply #15 on: April 21, 2012, 12:13:05 pm »
Folder ... meant file.  Not really much of a computer tech. Sorry.  I used Notepad and Microsoft Word.  Tried Plain Text and that still didn't work.  Don't know how to make it without the .txt extension.  Can you make one whereas you can send it to me? [In a Bones McCoy Voice] D*mmit Jim, I'm a Daycare Provider/Tax preparer, not a computer tech!  :D
 

Dorax Windsmith

Re: NWN Master Server
« Reply #16 on: April 21, 2012, 12:48:29 pm »
I've tried editing the file similar to what Xaltotun did and creating a new file.  I've used notepad and MS Word.  I don't see the option to "plain text file" with notepad but I did see that option with the save as command when using MS Word...the problem with that was when I dragged my "plain text file" into the etc folder the icon doesn't look like the other files in there which can't be edited (and I already deleted the original hosts file).  Even without the .txt extension, when right-clicking and viewing the file properties, it's still saving as a .txt file.  I'm using MS 7 Home edition....maybe it's my operating system?  I'm logged in as the administrator, but nothing seems to be working.

Any other suggestions or ideas?
 

Aphel

Re: NWN Master Server
« Reply #17 on: April 21, 2012, 01:41:41 pm »
I'm using Windows 7 Home Premium and it worked perfectly for me when using Notepad++
 

Chazzler

Re: NWN Master Server
« Reply #18 on: April 21, 2012, 07:51:01 pm »
You can select the file, right click with your mouse, select Rename and then press the arrow to the right button, which takes you to the end of the name of the file, then tap the backspace until .txt is removed from the name of the file.

If you can't for some reason see the .txt suffix, you need to (in Windows 7, and most other more modern Windows OS'), click on the folder's top left corner's Organize button (might be that name, mine is finnish in language, so there might be slight differences), from there select Folder And Search Options -> from the upper top side of three options, select Show, scroll down to the bottom, and you'll see a checkbox with "Hide the suffixes of known file types" or somesuch, on top of the selection of "Hidden Files And Folders". Uncheck the box and you will be able to see the .xyz .txt etc suffixes of all your files.
 

Dorax Windsmith

Re: NWN Master Server
« Reply #19 on: April 23, 2012, 01:15:32 am »
Success!  Thanks Chazzler....after changing that folder option, I was able to use the right-click/properties for the hosts file and delete the extension which worked!  Thanks for bringing this up Script Wrecked....you wouldn't think that the 5 seconds or so is that big a deal, but not waiting for that to process is really nice.