The World of Layonara  Forums

Author Topic: NWN on Mac?  (Read 310 times)

jadewillow

NWN on Mac?
« on: October 02, 2018, 11:07:23 pm »
Hey gang, anyone tried this yet? What is the min release you need for Layo again?

Hope all are doing well!

https://store.steampowered.com/app/704450/Neverwinter_Nights_Enhanced_Edition/
 
The following users thanked this post: Chazzler, willhoff

Acacea

Re: NWN on Mac?
« Reply #1 on: October 03, 2018, 11:24:10 am »
Yep, you can see here some of the info I was compiling for it when during beta. A lot of that is outdated, there have been further developments and new things, eg toolset works again in Linux with Wine. I meant to update later, but there was still a weekly dev patch at the time so I couldn't keep up :)

You can't use it to play on Layo, which is not running on EE and is still on version 1.69. I think this is still true:
Quote
I'd encourage anyone that wants to support NWN's future to buy EE (it's worth noting that Steam takes a big bite out of that if you get it from there), though obviously if you are only interested in NWN insofar as it involves Layo, don't rush to the bank because I think you'll be alright until further notice :)

I'm not a big fan of the OC, so if I were someone whose only interest in NWN was Layo and the OC, I would not buy it or recommend it -- provided I could actually run 1.69, which is of course not true for a lot of people on modern systems. I love NWN though, so I'm happy it was picked up and is being actively developed, again - especially by people pulled from the modding community.
 
The following users thanked this post: Chazzler, willhoff

jadewillow

Re: NWN on Mac?
« Reply #2 on: October 03, 2018, 10:19:10 pm »
Thank you. Let me be a bit more direct. Is it possible to run Layo on Mac without an emulator today?
 

Acacea

Re: NWN on Mac?
« Reply #3 on: October 03, 2018, 11:38:03 pm »
I've never used a mac; the last I heard running 1.69 on one needed Wine. (Since it's Not an Emulator, I guess that technically counts? :P )
« Last Edit: October 03, 2018, 11:40:40 pm by Acacea »
 
The following users thanked this post: jadewillow

WarriorOfTheLance

Re: NWN on Mac?
« Reply #4 on: October 06, 2018, 02:30:29 am »
Yep, you can see here some of the info I was compiling for it when during beta. A lot of that is outdated, there have been further developments and new things, eg toolset works again in Linux with Wine. I meant to update later, but there was still a weekly dev patch at the time so I couldn't keep up :)

You can't use it to play on Layo, which is not running on EE and is still on version 1.69. I think this is still true:
Quote
I'd encourage anyone that wants to support NWN's future to buy EE (it's worth noting that Steam takes a big bite out of that if you get it from there), though obviously if you are only interested in NWN insofar as it involves Layo, don't rush to the bank because I think you'll be alright until further notice :)

I'm not a big fan of the OC, so if I were someone whose only interest in NWN was Layo and the OC, I would not buy it or recommend it -- provided I could actually run 1.69, which is of course not true for a lot of people on modern systems. I love NWN though, so I'm happy it was picked up and is being actively developed, again - especially by people pulled from the modding community.

What problems are people having on modern systems? We've got 1.69 running on modern systems here, core i7, nvidia 1070 ti and gtx, windows 10... haven't had any issues... I keep hearing about issues, but i've never seen them... can you explain?
 

WarriorOfTheLance

Re: NWN on Mac?
« Reply #5 on: October 06, 2018, 02:33:15 am »
@Jadewillow, I can test out the Mac osX if you like.
 

Chazzler

Re: NWN on Mac?
« Reply #6 on: October 06, 2018, 09:57:18 am »
I don't know, but this might be of help?
https://www.youtube.com/watch?v=vhswa5LHM2M
 

Acacea

Re: NWN on Mac?
« Reply #7 on: October 06, 2018, 08:57:44 pm »
Yep, you can see here some of the info I was compiling for it when during beta. A lot of that is outdated, there have been further developments and new things, eg toolset works again in Linux with Wine. I meant to update later, but there was still a weekly dev patch at the time so I couldn't keep up :)

You can't use it to play on Layo, which is not running on EE and is still on version 1.69. I think this is still true:
Quote
I'd encourage anyone that wants to support NWN's future to buy EE (it's worth noting that Steam takes a big bite out of that if you get it from there), though obviously if you are only interested in NWN insofar as it involves Layo, don't rush to the bank because I think you'll be alright until further notice :)

I'm not a big fan of the OC, so if I were someone whose only interest in NWN was Layo and the OC, I would not buy it or recommend it -- provided I could actually run 1.69, which is of course not true for a lot of people on modern systems. I love NWN though, so I'm happy it was picked up and is being actively developed, again - especially by people pulled from the modding community.

What problems are people having on modern systems? We've got 1.69 running on modern systems here, core i7, nvidia 1070 ti and gtx, windows 10... haven't had any issues... I keep hearing about issues, but i've never seen them... can you explain?

People who like things to "just work", not "could not possibly get to work". There are lots of people that don't have 1.69 working, anymore. Can work, yes, "works automatically and without tweaking", not always and not for everyone. I'm fine with tweaking, hence why I continue with NWN forever and ever, but not everyone wants to deal with the various methods of running games on changing systems as they age.